9 Comments

  1. Lebrel

    Thank you very very much Linerd for your instructions about wifi conection. It works like a charm !!!!! Finaly I'm connected !!! I'm using Jaunty kernel 2.6.28-15.

    Reply
    • Linerd

      Lebrel - The native Linux driver for the RT2700 is now included in the kernel.

      I'm not sure if I like the Linux driver better though. There seems to be a small, constant stream of data always being received even when I'm not doing anything that uses the network. I didn't see this with the Windows drivers. I'm not sure yet how this affects battery life.

      Reply

  2. Thanks for the careful write-up - but even with your suggestions for manual partitioning, I run into the same wall I've experienced with previous efforts to set up a dual boot.
    Either: I let the installer put the bootloader on the basic level of the disk - where, I assume, it overwrites the MBR and/or partition table information needed for a proper boot for windows - because once I do this, I get a boot menu; Ubuntu will boot just fine - but the windows boot stalls and fails after the initial splash screen.
    Or: i tell the installer to load the bootloader onto the / partition (your 10GB ext 3) - but then on reboot, nothing happens - rather, I get one blinking cursor, and then a line down, the blinking cursor again.
    I have a Wind U100, I've put in a 160gb disk, and I keep having to clone (using clonezilla) the old 80gb disk back onto it in order to restore a bootable windows.
    What's the secret for getting from the manual partitioning you describe to a complete installation that will allow me to dual boot successfully into either Windows or Ubuntu?
    Thanks in advance for any help you can offer!

    Reply
    • Linerd

      Charles - You do want to let it install the boot loader to the MBR. That's the only way I know of to make it work. Linux doesn't seem to like working with unclean NTFS file systems, so make sure to shut down XP properly prior to installing Ubuntu. That is, after cloning the 80GB image onto your 160GB disk, make sure to boot into Windows and then shut down.

      I had a similar problem on my first Linux install. Not knowing about GParted, I had used Partition Magic to partition prior to installing SUSE Linux. After the partitioning, Windows would not boot. I had to boot to a Windows CD in DOS mode and run chkdsk c: /f to get it to boot. Here's the instructions for chkdsk.

      You may want to try just partitioning from the Live environment and then try to log back in to Windows. This would at least tell you if it's an issue with the partitioning vs. the MBR.

      I hope this helps.

      Reply
  3. Anonymous

    I got things to work by blacklisting some default drivers. See section 3.1 of the website given below.

    https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

    The required .inf file was always available to ndiswrapper. Yet ndiswrapper wasn't working. I thought the problem was the location. Clearly that was not the problem.

    Thanks for your help and excellent writeup. My next project is to get dual monitors to work on 8.10.

    cheers,
    s

    Reply
  4. Linerd

    Not sure why the OS_Install partition isn't showing up. Do you have the ntfs-3g package installed? You can check with
    dpkg -l | grep ntfs-3g

    If not, you can install with:
    sudo apt-get install ntfs-3g libntfs-3g23

    Alternatively, you can boot your Wind into XP and copy all of the files from the C:\WINDOWS\system32\DRVSTORE\rt2860_longstringofcharacters\ folder onto a flash drive. Then boot back into Ubuntu and copy those files into a folder in your home directory. Then go to configure the Windows Wireless Drivers and pull the rt2860.inf file from your new folder in your home.

    If you no longer have your XP installation, then it looks like you can download the files over BitTorrent. I found a torrent listing on Linux23.com.

    Reply
  5. Anonymous

    Thanks for the quick response. I have installed all three packages but some how the wireless just doesn't work.

    I have dual booted my msi wind and tried your ndiswrapper instructions. I cannot see OS_install in my "Places" but see the other six items (with the appropriate substitution for jon).

    Just a mention, I have 8.10 and not 8.04 installed.

    thanks again,
    s

    Reply
  6. Linerd

    S,

    Thanks for the comment. I've updated the apt-get command to include the other required packages.

    I've also added a paragraph about mounting the Windows partition so that you can find the /media/OS_Install directory. This of course assumes that you left Windows on your machine rather than wiping the drive completely for Ubuntu.

    Reply
  7. Anonymous

    This would be great if it works. But right now after installing ndisgtk (using either synaptic package manager or sudo command) the /media directory only contains cdrom and cdrom0 files.

    Do you know any work arounds?

    thanks,
    s

    p.s: never got an option to download other dependencies.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>